Payment Provider Down

Incident Report for Payments AI

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 06:11 MDT

Update

We are continuing to monitor for any further issues.
Posted Apr 24, 2025 - 05:16 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2025 - 05:16 MDT

Update

We have pinpointed the underlying cause and begun implementing corrective measures. We will keep you informed of our progress as the work advances.
Posted Apr 24, 2025 - 04:16 MDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 24, 2025 - 03:39 MDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 24, 2025 - 03:02 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 24, 2025 - 02:21 MDT
This incident affected: API and Backend Processors (Rebilly).